Known Issues

Known incompatibilities, issues, problems

Planar Face calculation points error in Revit 2018
Issue Autodesk made a breaking, albeit vaguely documented, change in the Revit 2018 API that causes legacy applications to throw an exception when the u...
Tue, 16 May, 2017 at 1:57 PM
Revit Material Libraries/Rendering is currently not supported error.
Issue ElumTools uses a feature of the Revit API called the Graphics Pipeline Custom Exporter to determine the View Visibility of elements during the cal...
Wed, 8 Nov, 2017 at 1:32 PM
Bluebeam Revu 2017 Incompatibility
 Issue UPDATE:  Bluebeam has released a patch that resolves this issue (release notes, FAQ). Bluebeam Revu 2017 is incompatible with ElumTools (all ...
Thu, 31 May, 2018 at 3:16 PM
ElumTools 7-Zip DLL conflict.
Issue When ElumTools is run along side another Revit Addin that uses the 7-Zip library, conflicts can occur. The main problem.  ElumTools throws an err...
Wed, 22 Nov, 2017 at 1:15 PM
Error during calculations: HeliosViewer has stopped working
Background: This error is produced by the inability of the geometry parsing routine to resolve certain elements in the scene. These are typically very c...
Thu, 22 Mar, 2018 at 9:19 AM
Calculate Boundary commands do not detect host model elements.
Background Autodesk introduced a bug in Revit 2017 which can cause the project Phase information to become corrupted when using the Wire command.  Thi...
Wed, 11 Jul, 2018 at 3:34 PM
Why are items from the wrong phase (e.g. demoed elements) being included in the calculation?
ElumTools does not have access to linked model Phase Mapping information (due to limitations in the Revit API). Because of this, demolished elements from li...
Thu, 29 Dec, 2016 at 2:38 PM
Antivirus software can affect the activation of the program
Issue: The Lai.LicenseManager.exe file was flagged as a false positive in the Malware Database and it triggers antivirus software to quarantine it. This...
Wed, 29 Mar, 2017 at 4:17 PM
ElumTools 2015.11, 2016.8, 2017.4 Commands using 3D graphics fail on system with .NET 4.5
Issue When you try running an ElumTools command that utilizes 3D graphics, you get an error message that the DLL cannot be loaded.  Solution  Th...
Thu, 6 Apr, 2017 at 4:23 PM
JSON.Net Incompatibility
FIXED in ElumTools 2015.11, 2016.8, 2017.4 and later. ElumTools uses a popular 3rd party library called JSON.Net.  In previous versions of ElumTools, th...
Tue, 21 Feb, 2017 at 9:22 AM